User Manual for BSA Ver 3.53B2 (Bispectrum Analyzer for BIS A2000/XP version)


Jump to English Manual


目次

1.はじめに
2. BSAの概要
3. BSAのインストール
4. A-2000の接続
5. BSAの操作方法
6. データ処理のアルゴリズム
7. データフォーマット
8. 変更履歴
9. おわりに

1. はじめに

麻酔深度モニターとしてBISモニターが脚光を浴びていますが,BISの算出方法は完全には公開されていないため,scientificな考察を行う際には問題があります. そこで,BISの要であるBispectrum Analysisを行い,BISを算出する元となる3つのsub-parameterを計算するBSA(Bispectrum Analyzer)を作成しました. BSA for A2000は脳波計の代わりにBISモニター(A-2000)からの脳波出力を利用するものです.A-1050を使用している場合にはBSA for BIS(A-1050用)を使用して下さい.
BSAでは原波形をreal timeに表示しながら,Bispectrumそのものを演算ごとにColor Spectrumで表示しノイズの状況なども把握しやすくしています.BSAはreal time処理のためのOnline modeと,既に取り込まれたデータを後から解析するOffline modeの2つのモードを実装しています.
必要なシステムスペックは現在のWindowsマシンならどれでも十分だと思います.CPUとしてPentium 100MHz以上のCPUと20MB程度のメモリーと800x600(SVGA)以上の解像度で216 色以上のビデオシステムがあれば動作します.Ver3.22B以前のバージョンではWindowsNT/2000/XPで動作させた場合,環境によっては動作中に画面の一部の更新が止まる問題が生じることありましたが現バージョンではこの問題点は解消されたと考えています.このバージョンではWindows XP/Vista/7でも動作します.

2. BSA for A2000の概要

BSA for A2000はBSAと同様にBorland社製C++Builder Ver5.0で開発されていましたが,Ver3.50からC++Builder XE2に開発環境をupdateしました.それに伴いファイル名に英数字以外の文字も使用できるようになっています.インストーラーも新しくなりました.
BSAはBispectrum/Bicoherenceをreal timeに表示するためにColor Spectrumを用いています.オプションでGray Scaleにすることも可能です.但しGray ScaleよりもColorの方が解りやすいと思います.これにより視覚的にも解りやすくかつ,高速な描画を可能としています.Ver3.00以降ではBispectrum/BicoherenceおよびPower spectrumの表示間隔を10秒に変更(V2.xまででは1分)し,より迅速に脳波変化を検出できるようになっています.なお,Bispectrum/Bicoherenceの算出に使用する脳波の長さは最近の1,2,3,4,5分のいずれかから選択可能(デフォルトは3分)とし,Power spectrumについては20秒,30秒もしくは1分のいずれかから選択可能(デフォルトは1分)にしました.Time Domain Analysisに関しては1分に固定しています.BispectrumおよびPower Spectrumについては得られたデータを有効epoch数で割って1 epoch当たりに換算するようにしています.Bispectrumは有効epoch数が60未満の場合には表示されません.BispectrumおよびPower Spectrumはいずれもその対数をスケーリングして表示しています.また,BSRについては演算区間のうち有効波形が20%未満になると表示されなくなります.脳波波形そのものも4秒分の波形を1秒毎に表示するようにプログラムされています.Power Spectrumは表示されているBispectrumと同じ解析区間のものが表示されるようになっています.
ノイズ対策はBISからのPacket Informationを取り込んでartifact checkingを行っています.また,元のBSAで実装した電気メスのノイズやスパイク的なノイズの自動判別はそのまま残してあります.


3.BSA for A2000のインストール

BSA for A2000本体はインストーラーから簡単にインストールできます.インストーラーの指示に従えば簡単にインストールできると思います.
V3.50からデフォルトでは"C:Bsa_A2000"以下にインストールされるようにしています. これはWindowsのUAC (User Access Control)に起因する問題を回避するためです.

4.A-2000の接続

A-2000/XPとの接続は9pinのストレートタイプのRS232Cケーブルを使用します.A-1050ではクロスタイプでしたからA2000用にケーブルを準備する必要があります.また,コネクタもA-2000側はオスのものを接続するようになっていますから注意して下さい.接続後,A-2000を起動しAdvanced Setupを開き,さらにDiagnostic Menuを選択します.ここでSerial Portの設定をBinaryにします. この後設定をSaveしておきます.これで準備完了です.最近のWindowsのコンピュータにはシリアルポートが付けられていませんので,Windowsで使用できるUSB-Serialコンバータを別途入手して下さい.お奨めはKeySpanのUSA-19HSなどです.大抵のもので動作すると思います.

5.BSA for A2000の操作方法

5-1. BSA for A2000の起動

インストールラーでインストールした場合にはスタートメニューのプログラムの中にBSAが組み込まれていますから,ここから起動して下さい.前もってショートカットのアイコンを作成しておけば,これをダブルクリックだけで起動できます.
A-2000のRS232Cポートからは57600bpsでデータが送られてきます.これを無手順で正しく受信しながら演算する必要がありますので,BSA for A2000を動かす時には他のアプリケーションは動かさないで下さい.通信エラーでパケットが落ちてしまう可能性があると思います.

5-2.オプション設定

起動したら最初に初期設定を行います.メニューバーの"Options"から5つのタグが選択できます.これらを順次選択して設定を行います.

[注意]
各Boxで入力した数値は"Apply"ボタンを押さないと有効になりません.設定したら"Close"の前に必ず"Apply"ボタンを押して下さい.

5-2-1. 各種オプション設定

(1) 波形処理のオプション

BSAではSEF95 (Spectral Edge Frequency 95%)もしくはSEF90と,BISのsub-parameterであるBSR (Burst Suppression Ratio), RBR (Relative βRatio), Bisp Ratio (SynchFastSlowと同等と推定される)の3つおよび平均振幅(Amplitude)とBIS値を経時的に表示するようになっています.V2.xまでは,BIS内部で計算している3種類のバージョンのBIS値もLogに取り込んでいましたが,あまり必要性を感じませんでしたのでV3.00以降では,モニター本体に表示されるBIS値のみを記録するようにしています.
取り込まれた脳波はまず最初にArtifactのチェックに掛けられ,その後移動平均によるbase line driftに対する補正が掛けられます.BSAでは前後0.5秒(合計1秒)もしくは前後1秒(合計2秒)の間の振幅が平均され,その値が元の振幅から引かれたものがProcessed Waveとして処理されます.なお,移動平均計算時にOvershootを除いています.
4つのパラメータのうちBSRについては常にこのProcessed Waveを使用しています.残りの3つのパラメータについては,Raw Wave (原波形), Moving_Average_1(1秒の移動平均によるbase line補正),Moving_Average_2(2秒の移動平均によるbase line補正)の3種のうちから選択できるようになっています.(BSRはMoving_Average_1またはMoving_Average_2のみです.) これらの選択はメニューバーのOptionのSet Processingで行うことができます.デフォルトの設定ではMoving_Average_1を使用するようになっています.
さらに,ここではBS (Burst Suppression)のSuppressionの閾値,Overshootの閾値,およびSpike判定の閾値がμV単位で設定できます.基本的には閾値の設定は触らないで下さい.
Ver1.20からOfflineモード時にパラメータのみを再計算するためのモードを追加しました."Calculation Only"のチェックボックスにチェックを付けるとこのモードになります.このモードではグラフィック表示せず(トレンドはSet Proccessingのオプションで表示・非表示の選択が可能)にパラメータだけを計算してLog Windowに書き出します.これによって処理方法を変えながらパラメータの再計算を高速に行うことができます.
BISモニターでは61.5秒分の脳波からBispectral Analysis由来のパラメータであるSynchFastSlowを算出しているとされていますが1) ,私の解析ではこの長さでは3分程度の区間から算出しなければ信頼できるBicoherenceが得られないことが判明しています.6) ただBISモニターではBicoherenceではなくBispctrumを用いており,さらに2つの異なる領域のBispectrumの和の比の対数をSynchFastSlowパラメータとして利用しているため現実には61.5秒から算出しても大きく変動しません.尤もこの場合Bispectral Analysisの真の利点であるphase couplingの程度をうまく利用できません.SyncFastSlowはほとんどPower sepctrumの変化を見ているに過ぎないのです.このためBsaではデフォルトで3分(正確には181.5秒)の脳波を用いてBispectral Analysisを行うように設定しています.BISと同じ区間で演算を行いたい場合には区間の設定を1分に変更してください.
V3.00以降ではPower spectrumの算出区間およびBispectrumの算出区間をそれぞれ別個に設定できるようになっています.デフォルトではPower spectrumは1分,Bispectrumは3分としています.演算間隔はすべて10秒間隔で行うように変更しましたが, LowWindowに書き出される間隔については別にオプションで設定変更ができるようになりました.デフォルトは1分です.データバッファにデータが記録されている時にこの設定変更を行うとLogWindowの更新を促すMessage Boxが表示されますので,更新したい場合にはYESを選択してください.

(2) 表示選択

あとは表示波形の選択とOffline時の再生速度の選択です.これはOptionのSet Viewで行えます.取り込まれたままの波形は黄色で表示され,base line補正を行った波形は赤色で表示されます.Set Viewではこの2つの波形の表示・非表示を選択できます.表示速度(演算速度)はx1(real timeと同じ)からx8(real timeの8倍)まで選択できます.なお,再生速度はCPUのパワーに依存します.遅いCPUでは設定通りの速度が得られません.
"Wave Form Scale"は脳波波形を表示する時のスケールです.デフォルトの2では±50μVまで(最大±70μV)表示できます.±100μVまで(最大±140μV)表示したければ1を指定して下さい.
なお,このサブメニューは波形処理中でも使用可能です.

(3) 接続するRS232Cポートの選択

V3.00以降ではCOM portの設定はメインパネルからOptionsのCOM portのタグに移動しました.EEGチャンネル設定についてもここに移動しています.現在のBIS sensorを用いるA-2000の場合1chのみしか使用していませんからch 0に固定しておいてください.
BIS A2000/XPの脳波の出力サンプリング周波数は128Hzもしくは256HzですVer 3.50以前のBSA_A2000ではこの周波数を128Hzに固定していましたが,Ver 3.50から256Hzもサポートするようになりました.これによってBISモニターから256Hzサンプリングの脳波データを取り出すことも可能となりました.

5-2-2. Bsa_A2000.iniファイルの書式

Bsa for BIS A2000 versionではオプションで設定できるパラメータをBsa_A2000.iniファイルに予め書いておくことができます.この設定は起動時に読み込まれ適切な値の場合のみ初期値にオーバライドする形で設定されます.書式はすべてラベル名と設定値のペアで区切りには":"が使用されます.":"の前後にスペースを挟まないで下さい.また,行頭が"#"で始まる行はコメント行としてすべて無視されますので必要なコメントを書くことができます.適当なエディタを用いて編集してください.
  1. Wave_Scale: 波形表示のスケールです.±100μVまで(最大±140μV)表示したければ1をそれ以外はデフォルトの2を使用して下さい.
  2. Moving_Average: 移動平均を取る区間の長さ(sec)を設定します.設定可能値は1または2のみです.デフォルトは1です.
  3. Overshoot_Threshold: 電気メスなどの電気ノイズを検出するための電位閾値の設定です.デフォルトは150(μV)です.100未満の設定はできません.
  4. Spike_Threshold: Spikeノイズの検出閾値です.1/128(sec)での変位電圧で設定します.デフォルトは80(μV)です.10未満の設定はできません.
  5. BS_Threshold: Burst Suppressionのcriteriaを設定する電位閾値です.デフォルトは5(μV)です.1-5の値が設定できますが,通常は変更しないで下さい.
  6. Show_Raw: raw EEG waveの表示指定です.trueまたはfalseで指定します.デフォルトはfalseです.
  7. Show_Proc: processed EEG waveの表示指定です.trueまたはfalseで指定します.デフォルトはtrueです.
  8. Defect_Str: Log Windowに表示される欠損値を表示する文字列を指定します.デフォルトでは"***"です.NULLを指定すると何も表示されません.NULLはlogファイルを後からMicrosoft Excelで処理する場合などに便利なように作成されています.
  9. WorkDir: EEGの波形データやLogファイルを置くディレクトリを設定します.何も指定しない場合にはBsa_A2000.exeの作業ディレクトリになります.
  10. Proc_Trend: V1.30以降ではEEGサブパラメータのトレンド表示が可能になりました.トレンドを使用する場合にはtrueを,しない場合にはfalseを設定します.デフォルトはtrueです.
  11. COM_Port: A-2000を接続するシリアルポートの指定をします.COM1-COM16のうちの一つが0-15で選択できます.
  12. Use_BIS_BSR: A-2000からのBSRの替わりに自前で計算しているBSRを使用する場合falseを設定します.デフォルトはtrueです.
  13. Power_Dur: SEFやRBRを算出する演算区間(時間)を20sec,30sec,1minのいずれかから選択できます.デフォルトは1min(1分)です.
  14. Bisp_Dur: Bispectrum/Bicoherenceを算出する演算区間(時間)を1min,2min,3min,4min,5minのいずれかから選択できます.デフォルトは(3min)3分です.
  15. LogInterval: Logウィンドウに書き出すデータの間隔を指定します.10sec,20sec,30sec,1minのいずれかを選択できます.デフォルトは1minです.
  16. Maxmem: データを保存する領域の設定を時間単位で行います.デフォルトでは24時間分の算出パラメータを記憶可能ですが,旧いシステムによっては十分なメモリーが搭載されていないことも考えられます.そのような場合にはこの設定を小さくします.また、逆に24時間を超えてデータを取りたい場合もあるでしょう.そのような場合にはこの値を増やしてください.8時間未満の設定に関しては8時間に設定されます.ソフトウェア的な上限は設けていませんので,システムに搭載されたメモリーにのみ依存することになります.設定された時間を超えて記録を続けた場合順に古いデータが上書きされてしまいます.ただし,LogWindowの内容に関しては単純に追加されていきます.
  17. AutoRec: この設定をtrueにしておくとOnlineモード時には常にパケットデータをファイルに記録するようになります.ファイルはWorkDirが設定されていればそのディレクトリに,なければBsa_A2000.exeの作業ディレクトリに作成されます.ファイル名は年月日に1-99までの番号が付いたものになります.必要に応じてあとから変更してください.なお,1-99のすべてのファイル名のファイルがすべて存在する場合にはStartボタンを押した時に記録するファイル名を指定するダイアログボックスが表示されます.デフォルトはfalseです.
  18. CommentOnLog: V3.00以降ではコメントを独立したWindowに記録するようになっています.このオプションをtrueにすると,V3.00以前のバージョンのようにLog Windowの各行の後にもコメントが追加されます.デフォルトはfalseです.
  19. Child: 小児で使用する場合の脳波振幅が大きいためトレンドのスケールが足りません.このオプションをtrueにすると振幅のスケールが変更できます.
  20. Pow_real: 以前のバージョンではパワースペクトルを対数目盛で表示していましたが,通常の目盛での表示もサポートしています.これをtrueに設定すると通常の目盛になります.
  21. SamplingRate: Ver 3.50から脳波のサンプリング周波数を128Hzもしくは256Hzに設定できるようになりました.この数値を128とすると128Hz,256とすると256Hzになります.デフォルトは128です.
以下にBsa_A2000.iniのサンプルを示します.変更の必要のない項目は省略できます.Bsa_A2000.iniファイルはBsa_A2000.exeと同じディレクトリに置かなければなりません.ここでWindows VISTA以降のUAC (User Access Control)が問題になります.
# Parameter settings

Wave_Scale:2

Moving_Average:1

Overshoot_Threshold:150

Spike_Threshold:80

BS_Threshold:5

Show_Raw:false

Show_Proc:true

Defect_Str:NULL

WorkDir:C:\EEG

Proc_Trend:true

COM_Port:0

Use_BIS_BSR:true

Power_Dur:1min

Bisp_Dur:3min

LogInterval:1min

AutoRec:false

Pow_real:true

SamplingRate:128

5-2-3.出力ファイル設定

メニューのファイルから"Save"を選択すると"Wave", "Power", "Bispec"の3種の選択タグが表示されます.Bsa_A2000ではWaveは常にBinaryで保存されます."Power", "Bisecp"については"Binary"もしくは"ASCII"のモード選択があります.選択するとファイル名を設定するDialogが表示されますから,ここでファイル設定を行って下さい.出力ファイルのフォーマットについては7.のデータフォーマット を参照して下さい.

5-3. モード設定

メニューの"Mode"タグでOnline modeとOffline modeの選択ができます.

5-3-1. Online mode

デフォルトではOnline modeになります. 既に設定値をBsa_A2000.iniファイルに記述してある場合にはスタートボタンを押せば直ちに解析が開始されます.脳波データや計算されたBispectrumなどの情報をファイルに記録したい場合にはスタートする前にファイル名をメニューバーのファイルのところを選択して指定しておく必要があります.(V3.00以降ではAutoRecがtrueなら自動的にファイルに記録されます.)
BISモニターの接続が済めば,スタートボタンを押すだけで解析がスタートします.終了する時にはStopボタンです.算出されたパラメータは時刻と共にLog Windowに表示されます.必要に応じてここにコメントを加えることも可能です.Online modeではStop時にこのLog Windowをファイルに出力するかどうか尋ねるように作成しています.Logを残す場合にはファイルに出力して下さい.また,コメントファイルについても内容がある場合には同様にファイルに記録するかどうかを尋ねてきます.
このモードではパケットデータをファイルに記録中は"On Recording"表示がtrend画面の上に表示されます.

注意!!

スタートボタンをクリックした後に波形が表示されず,"A2000 did not respond"と表示された場合にはA2000のSerial portの設定がBinaryになっているかどうかを確認して下さい.

5-3-2. Offline mode

Offline modeは一度記録した脳波波形を再度処理する場合に用います.メニューバーのModeでOfflineを選択するとファイルを開くダイアログが表示されます.
Offlineモードでは,再生用ファイルはモードが切り替えられるか新しいOffline用ファイルが指定されるまで有効です.Startボタンを押す度に先頭から再生されます.一時的に波形を止めたい場合にはPauseボタンで止まります.再開はこのボタン(Contボタンになっている)を再び押せば再開します.処理を止めてしまう時にはStopボタンを押して下さい.ファイルの途中から再生したい場合にはSetViewの画面で処理を開始したい時刻をトラックバーとleft-rightボタンで指定してください.あまりに長い時間記録されたパケットファイルに関してはこのトラックバーがうまく働かないかもしれません.現在対応策を考慮中です.
Offline modeでは再生速度をx1からx8まで変更できます.これはメニューバーのオプションからSet Viewを選択して設定します.このオプションはOffline用のファイルが選択されている場合のみ有効です.
SetProcで"Calculation Only"が設定されている場合には画面表示は行わず,常にフルスピードでパラメータのみの算出を行います.この場合にはPauseボタンは使用できません.

5-3-3. 処理中の操作

(1) Trend画面の操作
V3.00以降ではTrend画面はメインパネルに置かれていますので,SVGAの画面で脳波波形やBispectrum/Bicoherence, Power spectrumと同時にTrendを見ることができるようになりました.
また,トレンド画面にはSEF, BSR, RBRとf1 =f2 の対角線付近のbicoherenceの平均値がcolor spectral scaleで表示されます.これまでの私の研究では麻酔レベルによってBicoherenceが変化する領域は上記のような対角線付近に比較的限局しており,この部分のトレンドが最も臨床上参考になると考えたためこのトレンドを加えました.aBIC(f)の計算にはBIC(f1 ,f2 ) = BIC(f2 ,f1 )が考慮されています.実際にはaveraged Bicoherence (aBIC)としてaBIC(2Hz)からaBIC(15Hz)を0.5Hzステップで算出・表示しています.


aBIC(f) = { BIC(f,f)+BIC(f+0.5,f)*2+BIC(f+0.5,f-0.5)*2+BIC(f+1.0,f-0.5)*2 +BIC(f+1.0,f-1.0)*2+BIC(f+1.5,f-1.0)*2 }/11
V3.00以降ではTrend表示の時間幅は2時間に固定されていますが,画面右上のスクロールボタンで左右に1時間単位でスクロールできるようになっており過去のデータも見ることができるようになりました.

(2) Comment入力
Ver2.00B以降ではon lineモードでのComment入力オプションが追加になっています.intubation, extubationなどのよく用いられるコメントは予め登録されていますので,キー入力することなくコメントをComment Windowに追加できます.それ以外のものはBox内に直接書きこんでApplyボタンを押して下さい.V3.00以降ではコメントはコメントファイル(.cmt)にデータログとは分離して記録するように変更されています.また,コメント入力ウィンドウには同時にコメントボタンが押された時刻も表示されます.この時刻通りでよい場合にはコメントだけを書きこんでApplyボタンを押せばこの時刻が記録されます.時刻の変更が必要な場合にはここで時刻も変更してください.なお,Optionタグから直接コメントウィンドウを開いて編集することも可能です.

(3) Bispectrum, BicoherenceとTriple Productの表示選択

これらの3種の算出値のうち選択された1種が画面に表示されます.メインパネル左上のコンボボックスで選択してください.デフォルトはBispectrumです.


(4) Log Windowの操作
"Log Window"はBsa V1.10以降では独立したWindowに変更されました.Log Windowを開くにはWindowメニューのOpen Logのタグで行います.V3.xでは算出された時刻と算出されたBSR, SEF95(またはSEF90), RBR, BispRatioおよびBISモニターに表示されているBIS Indexの値と平均振幅,さらにTime Domain, Power Domain, Bispectral DomainのSQI(Signal Quality Index)もLog Windowに書き出されます.V2.xとは書き出されるデータが異なることに注意してください.平均振幅は振幅が5μV以上の波形のみを対象に算出しています.V3.00以降ではコメントは時刻と共に別ウィンドウに記録されるように変更されました.'Online mode'の場合には"Stop" ボタンを押した時にLog Windowの内容をファイルにsaveするかどうかを尋ねるダイアログボックスが表示されますからsaveする時にはここでファイル名を指定して下さい.'Offline mode'ではSaveする時には"Save Log"ボタンをクリックしてファイル名を指定する必要があります.単にクリアだけしたい時には"Clear Log"ボタンをクリックして下さい."Log Window"を閉じる場合は"Close"ボタンをクリックします.
V2.xでは,Log windowに記録されるデータの大きさは64KB以内に制限されていましたが,V3.00以降では特に制限はありません.メモリーの許す限り大丈夫だと思います.
このLogをファイルに記録しておけば後からExcelなどに読み込んで処理することができます.

(5) Comment Windowの操作
V3.00以降ではコメントウィンドウはData Logと分離されました.コメントウィンドウを開くにはWindowメニューのOpen Commentのタグで行います.Data Logと同様にOnlineモード終了時にはCommentバッファの内容もファイルにsaveするかどうかを聞いてくるようにしています.

(6) SQI (Signal Quality Index)について
V3.00以降ではメインパネル右下に3つの解析方法に対するSQIが棒グラフで表示されるようになっています.それぞれ80%以上の場合には緑色で,40-80%の場合には黄色で,40%未満の場合には赤色で表示されます.SQIは設定された区間のうち演算に有効であった部分の割合を示します.なおPower spectral AnalysisとBisectral Analysisでは1 epoch(2sec)のtotal powerが(Blackman windowを掛けて算出した値で)5μV2 未満の場合にはflat EEGと判断して解析から除いています.
なお,Time Domain Analysisに関してはBISモニターからのBSRを使用している場合にはSQIもBISモニターからのものが用いられます.

5-4. Versionの表示

メニューの"Version"をクリックすると"BSA for A2000"のバージョン番号が表示されます.最後に"B2"が付くのがA2000 versionです.

5-5. 処理の終了

"BSA"を終了させる時にはFileメニューの"Exit"タグをクリックするか画面右上のxマークをクリックしてください.処理の実行中にいきなり終了させることはできませんので,先に必ず"Stop"ボタンで処理を終了させた後でExitして下さい.

6.データ処理のアルゴリズム

6-1. base line 補正

5章で書きましたようにBSAでは最初にArtifactのチェックを行った後,原波形のbase lineを移動平均で補正します.
さて,Burst SuppressionのcriteriaはAmplitudeが5μV以下の区間が0.5sec以上続くことですが,RampilのReview1) にもあるように原波形に対していきなりこのcriteriaを当てはめるとbase line driftにより正確にSuppressionを捕らえられません.そのためにこのような補正を行っています.この波形に対し一次微分(差分)を元にpeak detectionを行いみかけのamplitudeを算出しながらBurst Suppressionの定義に当てはめてBSRを算出するようにしています.BISモニターがどのようなアルゴリズムでBSRを算出しているか不明であるため,BSAではこのようなアルゴリズムに基づくBSRのみ対処しています.デフォルトではBISモニターからのBSR出力をそのまま用いるようにしていますので,この部分はあまり問題にならないと思います.また現時点ではBISで用いられているQUAZIの算出方法は未公開であるためBSAではQUAZIの算出は行っていません.(ReviewではPower Spectral Analysisから得られる1Hz未満の成分を取り除いた波形に対して処理をしているとなっています.)
BSAでは移動平均を引くことでbase line driftを対処しています.移動平均は最も簡単なlow pass filterです.従って移動平均を差し引くとlow cut filterとなります.BSAではデフォルトではprocessed waveを処理するようにしています.
なお,前後0.5秒もしくは1秒の移動平均を取りますので,実際に演算・表示を行う波形は実時間よりも0.5秒もしくは1秒遅れたものになります.BISからのartifact情報を利用するために現実にはさらに2秒程度の遅れが生じますが,この程度の遅れは問題にならないと考えられます.

6-2. Bispectral AnalysisとSynchFastSlow パラメータ

6-2-1. Bispectral Analysisの原理

Bispectral Analysisの詳細はSiglらの論文3) を参照して下さい.さらに詳しく知りたい方はNikiasらの論文5) を参照して下さい.ただNikiasらの論文を理解するにはかなり高度な数学的知識が要求されます.RamilのReview1) のBispectral Analysisの解説は正しくありませんので参照しないで下さい.他の論文と読み比べれば解説が正しくないことが理解できると思います.
ここでは,簡単に原理のみを解説します.Bispectral Analysisは2つの異なる周波数を持つ波の非線形的相互作用(phase coupling)を調べるものです.Siglらはphase couplingの簡単な例として入力の2乗を出力として返す関数を挙げています.入力をf1 ,f2 という周波数の2つの余弦関数の和とし,それぞれの位相をq 1 , q 2 とします.この時出力関数は以下のようになります.('t'は時間を示します.)

INPUT: x(t) = cos(f1 t+q 1 ) + cos(f2 t+q 2 ) OUTPUT: y(t) = 1 + cos[(f1 +f2 )t+(q 1 +q 2 )] + cos[(f1 -f2 )t+(q 1 -q 2 )] +1/2cos(2f1 t+2q 1 ) + 1/2cos(2f2 t+2q 2 ) この場合f1 +f2 ,f1 -f2 , 2f1 , 2f2 といった周波数の成分は元のf1 ,f2 という周波数の成分に依存したものになります.このような非線形的修飾(入力の加減算以外の演算)によってできた成分のことをIMPs (intermodulation products)と呼びます.IMPsでは上記の式で判るようにその位相が元の成分の位相に依存しています.このようなIMP成分をphase-coupledであると表現します.一方IMPではないような成分はfoundementalと呼ばれます.Bispectral Analysisは信号成分のうちphase-coupledであるような成分の存在や程度を調べる解析方法です.
もしもある波が異なる周波数を持つ波同士の線形結合である場合にはPower spectral Analysisで個々の周波数成分に分解できます.しかし非線形的な結合の場合にはPower spectral Analysisでは解析できません.Bispectral Analysisでは2つの異なる周波数f1 ,f2 とその和の周波数であるf1 +f2 を考えます.f1 ,f2 の波をそれぞれX(f1 ),X(f2 )とし,これらの位相をf1 t+q 1 ,f2 t+q 2 とします.また,f1 +f2 の波の位相を(f1 +f2 )t+q 3 とします.波は一般に大きさと位相という2次元のパラメータで表されこれは複素数として示されます.ここでX(f1 +f2 )の共役複素数をX* (f1 +f2 )とすればX* (f1 +f2 )の位相はX(f1 +f2 )の位相を反転したものになります.つまり-{(f1 +f2 )t+q 3 }です.ここでX(f1 ),X(f2 ),X* (f1 +f2 )の3つの積triple productを考えると,このtriple productの位相は(f1 t+q 1 )+(f2 t+q 2 )-{(f1 +f2 )t+q 3 } = q 1 +q 2 -q 3 となります.もしもq 1 , q 2 , q 3 の間に一定の関係(phase coupling)がない場合にはtriple productの位相は[0,2p ]にrandomに分布することになり,その結果としてtriple productの和の大きさ(bispectrum)は0に近づきます.しかしこれら3つの位相の間になんらかの関係があればtriple productの位相には偏りが生じその結果としてbispectrumは0でない値を取るようになります.このようにして位相のカップリング(phase coupling)を調べるのがBispectral Analysisです.

複素数と極座標表示

複素数と位相の関係について少し解説を加えます.
まず通常のx-y座標の代わりに極座標(大きさと位相)を導入します. 複素数 z = x + yi を考えます. (x,y) => (r , q ) r = sqrt(x2 +y2 ) cos q = x/sqrt(x2 +y2 ) sin q = y/sqrt(x2 +y2 ) とすれば z = r (cos q + i sin q ) ここで2つの複素数の積を極座標で考えます. z1 *z2 = r 1 (cos q 1 + i sin q 1 )*r 2 (cos q 2 + i sin q 2 ) = r 1 r 2 *{ (cos q 1 cos q 2 - sin q 1 sin q 2 ) + i (sin q 1 cos q 2 + cos q 1 sin q 2 ) } = r 1 r 2 *{ cos(q 1 +q 2 ) + i sin(q 1 +q 2 ) } 結局z1 *z2 の大きさは2つの複素数の大きさの積に,位相は2つの複素数の和となります.
このBISの目玉であるBispectral Analysisですがepochの長さやoverlappingの行い方にいくつかの選択枝があります.Nikiasら5) はoverlappingはかぎられた区間からのデータからより多くのepochを得るために有用であると書いています.理想的には無限時間の加算を行わなければならないのですが,現実には有限時間の加算で代用しています.区間が短ければ算出されるbispectrumの分散は大きくなり,信頼性は低下します.Siglらの論文では1 epochは4秒で1秒ずつずらしながら加算していますが,BSAでは1 epochは2秒とし0.5秒ずつずらしながら加算する方式を採用しています.この方法はBIS monitor(少なくともA-1050およびA-2000)の方法と同じものです.これはAspect社から提供されているA-10X0 Serial port specification manual4) とRampilのreview1) から判明した情報です.なお,"BSA"ではBIS monitorと同様にFFTを行う前にBlackman window関数を掛けています.

6-2-2. SynchFastSlowパラメータ

さて,RampilのReviewではBISのsub-parameterのうちSynchFastSlowはBispectral Analysisから算出された値を用いて以下の式で計算しているとしています.


SynchFastSlow = log( B0.5-47.0Hz /B40.0-47.0Hz )


ここで問題となるのはBx-y です.Bx-y はfrequency to frequency spaceの両方の軸でx Hzから y HzまでのBispectrumの和と解説されています.使用するBispectrum値がBsaで表示しているような三角形の領域内だけということですが,それだとしても計算してみるとRampilのReviewに示されているような値にはなりません.ASPECT社に問い合わせたところSynchFastSlowではf1 +f2 <48Hzの範囲のbispectrumから算出しているという回答を得ましたが,SynchFastSlowの詳細な算出法に関しては返答はありませんでした.
さらに問題があります.同じReviewでのPropofol麻酔の実例ではこのパラメータは-1.35から-3.1まで常に負数になっています.しかしながらReviewの通りの式だと決して負数にはなりません.結局これは


SynchFastSlow = log( B40.0-47.0Hz /B0.5-47.0Hz )


であると推論し,BSAではこの値を表示しています.区別のためにSynchFastSlowではなくBispRatioと呼ぶことにしました.BSAでは,Bispectrumを0.5Hz<=f2 <=f1 <=47.0Hz(f1 +f2 <=47.5Hz)の範囲で計算しています.
私の計算式は推論によるものですから実際にBIS内で用いられているSynchFastSlowとは異なるかもしれませんのでBispRatioはSynchFastSlowとは別個のパラメータとして扱ってください.実際BSAで算出されるBispRatioはSynchFastSlowよりも負に傾いています. BIS Indexでは,SynchFastSlowはdeep sedationから通常の手術時の麻酔レベルで最も重いウェイトが掛けられています.これまでの私の解析ではBispRatioはこの麻酔レベルで麻酔レベルとある程度相関して変化していますのであながちおかしなパラメータではないと思います.

6-2-3. BispectrumとBicoherence

BSAではBispectrumの代わりにBicoherenceを表示させることもできます.BicoherenceはBispectrumをreal triple product(f1 ,f2 ,f1 +f2 の3つの周波数の波のPowerの積)の平方根の和で割って100にスケーリングしたものです.Siglの論文3) では和の平方根で割ると書かれていますが,これでは100にスケーリングできません.なぜならばBispectrumはベクトル和の大きさですから,これをスケーリングするにはベクトルの大きさの和で行わなければならないからです.本来はBicoherenceの方が2つの周波数の波の相互作用の程度を示す指標ですからBispectrumそのものを見るよりも意味があると考えられます7) .なおV3.00 以降ではBicoherenceを算出する場合の分母となるTriple Productも切り替えて表示できるようにしました.これでPower Spectrumに基づくTriple ProductとBispectrumがあまり大きく変わらないことが見て解ると思います.


複素数(ベクトル)の和の大きさのスケーリングに関して

複素数は2次元のベクトルとみなすことができます.ベクトルの和の大きさは以下の式のように個々のベクトルが同一方向を向いている時に最大となり,その値は個々のベクトルの大きさの和に一致します. 0 = | S zj | = S |zj | ところで S |zj | = S sqrt(|zj |2 ) です.
これをBispectrumに当てはめればtriple productは複素数ですからBispectrumは複素数の和の大きさということになります.一方triple productは3つの複素数の積ですからその大きさは3つの複素数の大きさの積になります.
さて,RTP(real triple product)は3つの複素数のPowerの積として定義されています. RTP = P(f1 )P(f2 )P(f1 +f2 ) これを用いればtriple productの大きさは以下のように RTPの平方根と等しくなります. | (triple product) | = r 1 r 2 r 3 = sqrt(r 1 2 r 2 2 r 3 2 ) = sqrt(P(f1 )P(f2 )P(f1 +f2 ))= sqrt(RTP) 従って Bispectrum = | S (triple product) | = S sqrt(RTPj ) 結局 Bicoherence = Bispectrum / S sqrt(RTPj ) * 100 (%) となります.

6-3. Burst Suppression Ratio

BISのサブパラメータの一つであるBSR and QUAZIですが,BSAでは先に解説しましたように移動平均でbase line補正を行った波形に対しデフォルトでは振幅が5μV未満の区間が0.5sec以上続いた場合をSuppressionと判定してSynchFastSlowパラメータを計算するのと同じ区間について結果を表示するようにしています.但し全波形のうち正常波形が20%未満の場合には値を表示しないようにしています.RampilのReviewによるとBISモニターではオリジナルのBSRのcriteriaではbase line driftのためにまともな判定ができないためQUAZIも計算しているとしています.QUAZIはPower Spectrum Analysisで得られたデータを用いて原波形から振動数が1Hz未満の成分を除去した波形に対して処理を行っていると書かれていますが詳細は公表されていません.現実にはQUAZIはburst and suppressionが出現するよりも少し浅いレベル(いわゆるpre burstの状態)を定量するために用いられているようです.BSAでのBSR判定はこれらとはalgorithmが異なります.
BSAでのSuppressionの検出アルゴリズムの概略を解説します.まず,artifact detectionで生き残った波形を128Hz samplingからさらに64Hz samplingに落します.これによって高周波ノイズの影響をさらに軽減させます.次にこの波形の1次微分を計算し,positiveおよびnegative peakを検出します.個々のpeak間の差の絶対値の半分を振幅と考え,これに対してsuppressionのcriteriaを当てはめてBSRを算出しています.この方法の場合base line driftがあってもほぼ確実にsuppressionを捉えることが可能でした.BISモニターを用いて比較した結果ではQUAZIとほぼ同じ値を示していました.
問題点としては比較的麻酔の浅い段階で振幅の小さな速波が主成分になっている場合にBSのcriteriaに入ってしまい本来のBurst Suppressionが0であるのに間違った値を算出することがあります.これについては今後の課題です.現時点ではBISモニタからの出力を利用することを推奨します.
BSR and QUAZIはBISでは麻酔の最も深いレベルで最も大きなウェイトを占めています.現実問題としてSuppressionが強くなると演算すべき脳波そのものが減少しますので他のパラメータの意味が小さくなることは当然と言えば当然です.

6-4. Relative β Ratio

BIS Indexでは11.0Hz-20.0Hzの波と30.0Hz-47.0HzのPower Spectrumの和の比の対数をRelative β Ratioとして算出し,麻酔の最も浅い部分で最も大きなウェイトが掛けられるようになっています.log ((P30-47Hz )/(P11-20Hz ))で計算されます.1)
ところで,Glassらの論文2) では30.0Hz-47.0Hzではなく40.0Hz-47.0Hzであるような記載があります.これについては現在ではASPECT社からの回答でRampilの記述1) が正しいことが判っています.

6-5. SEF95 or SEF90

SEF95(Spectral Edge Frequency 95)は全体のPower Spectrumのうちちょうど95%がその周波数以下に存在するFrequencyの値を指します.一般に麻酔が深くなるとこの値は小さくなります.BSAでは30.0Hz以下のPower SpectrumについてSEF95を算出しています.オリジナルのBSAではSEF90を計算していましたが,BISではSEF95を採用していることもありデフォルトではSEF95を使用し,オプションでSEF90が出せるようにしています.

7.データフォーマット

出力データ用のファイルはすべてStopボタンで処理が止められた段階でCloseされます.各データのフォーマットを以下に示します.

7-1. 波形データ

先頭の128バイトにheader情報が設定され,以後は正しく取り込まれたデータパケットのみがそのまま順に書かれます.

7-2. Power Spectrum, Bispectrumのデータ

これらはBinaryモードではsingleのfloat形式で記録されます.Power Spectrumについては0.5Hzから47Hzまで0.5Hz刻みで記録されます.Bispectrumは0.5Hz<=f2<=f1 <=47.0Hz(f1 +f2 <=47.5Hz)の範囲で(f1 ,f2 ) = (0.5,0.5),(1.0,0.5), (1.5,0.5),...(47.0,0,5),(1.0,1.0),(1.5,1.0),(2.0,1.0),.....(46.5,1.0),(1.5,1.5),(2.0,1.5).......................,(24.0,23.5)の順に記録されます.このモードではBispectrumが出力され,続いてReal Triple Product(f1 ,f2 ,f1 +f2 の周波数の波のPowerの積)の平方根の和が出力されます.
Bispectrumの配列のindex(0-2255)をf1 とf2 から求める換算式は以下のようになります.Index = (96-f2 *2)*(f2 *2-1)+(f1 -f2 )*2 ASCIIモードの場合にはBinaryモードと同様の順でデータが出力されますが,Bispectrum, Triple Productに関しては1行にこの2つがペアとして出力されるようになっています.各ブロックの先頭には'# hh:mm:ss,n'の形で時刻が記録されます. nは有効epoch数です.

8.変更履歴

1999.09.27 Ver 0.33 ほぼ目的の動作状態となる.
1999.11.14 Ver 0.70 BicoherenceからBispectrumへ表示変更
1999.12.09 Ver 0.85 演算ルーチンを整理
1999.12.14 Ver 0.94 Bsa.iniによる初期設定追加
1999.12.23 Ver 1.00 一応の完成版
1999.12.31 Ver 1.02 ASCIIモードでの波形データ記録ルーチン追加
2000.01.03 Ver 1.03 SEF90の演算領域を0.5-47.0Hzから0.5-30.0Hzへ変更 (pEEGやBISモニターに合わせるように変更しました.)
2000.01.11 Ver 1.05 Offlineモード時に解析を開始する時間を設定できる機能を追加.Calibration Mode modifed
2000.01.12 Ver 1.10 PowerspectrumをWaveformと同時に表示するように変更.Bispectrumのイメージは縮小.LogWindowを独立させた.
2000.01.21 Ver 1.11 Screen Display troubleの対策
2000.01.25 Ver 1.20 パラメータのみを高速に再計算させるモードを追加.また,この他表示ルーチンなど細かい点を改善.Wave Scaleの設定をSetViewに移動.
2000.01.30 Ver 1.21 画面表示が時々おかしくなっていた問題を修正.その他細かいbugを修正.再生速度のリミッタを追加.
2000.01.30 Ver 1.22 Log Windowに表示される欠損データを表示する文字列をBsa.iniで指定できるオプションを追加.Bsa.ini読み込み時のbugを修正.
2000.01.31 Ver 1.23 画面表示修正の追加.
2000.01.31 Ver 1.24 Bsa.iniにWorkDirオプションを追加.
2000.02.15 Ver 1.30 Trend画面を追加.
2000.03.25 Ver 1.31 PowerSpectrumのスケールを変更
2000.05.08 Ver 1.32B for BIS version 2000.05.14 Ver 1.33B データ入力部を再構成.
2000.06.30 Ver 1.34B online動作bug fixed.
2000.07.03 Ver 1.35B ほぼオリジナルのBSAと同等の機能の実装を完了.
2000.07.22 Manualの一部改訂
2000.09.07 Ver 1.35B03 Shortcut key 追加.SynchFSの表示をBispRatioに変更.
2000.09.28 Ver 1.35B04 online modeのtimer bug fixed. オリジナルのBsaに合わせて目盛りの文字を拡大.
2000.10.12 Ver 1.36B BispR bug fixed
2000.10.18 Ver 1.37B Bispectrumの計算範囲をf1 =f2 まで拡張.これに伴ってBispRatioの計算範囲も拡張.
2000.11.06 Ver 2.00B Bispectrumの計算区間の設定オプションを追加.コメント入力用ボタンの追加.
2000.11.23 Ver 2.10B BSRの計算アルゴリズムを改良.BISのartifact flagの利用ルーチンのbug fixed.
2000.12.28 Ver 2.20B power spectrum算出時のepochの取り方に関する深刻なバグの解消.平均振幅のパラメータをLog画面に記録するように追加.
2001.01.08 Ver 2.21B Time domain analysisルーチンを単純化.
2001.04.02 Manualの改訂
2001.05.31 Manualの改訂
2001.06.17 Ver 2.40B 描画Threadの常駐化
2001.07.15 Ver 3.00B Major Version up !!. Trend画面を改良し,さらにメインパネルに移動.演算間隔を10秒間に変更. コメントファイルの独立化.AutoRecモードの追加.SQIグラフの追加, etc.
2001.07.17 Ver 3.01B Trend廻りのbug fixed.
2001.08.02 Ver 3.02B Window Menuの追加. POST_OVER flagの追加,bicoherence変数の初期化追加,CommentOnLog flagの追加,メインパネルのボタン配置を変更.
2001.08.10 Ver 3.03B Trend処理の小さなバグ修正.
2001.10.06 Ver 3.04B OVERSHOOTの処理変更.
2001.10.29 Ver 3.05B OVERSHOOTの処理を元に戻す.
2002.01.14 Ver 3.06B Comment Windowへのfocus設定追加.Stop時の確認の追加.SQI graph描画変更.BSR scale変更.
2002.05.04 Ver 3.07B2 "B2" version is for A2000.
2002.05.09 Ver 3.10B2 最初の"BSA for A2000" β版リリース.
2002.05.14 Ver 3.11B2 ShowWaveThreadを変更.
2002.05.26 Ver 3.12B2 LockをTryLockに変更.
2002.05.27 Ver 3.13B2 TryLock変更忘れの修正.
2002.05.29 Ver 3.14B2 Trend Time bug fixed.
2002.06.09 Ver 3.15B2 Offspeed bug fixed.
2002.11.09 Ver 3.16B2 Work area too large bug fixed.
2002.11.14 Ver 3.17B2 Child mode added.
2003.05.25 Ver 3.21B2 TryLock routine modified for WinXP.
2003.11.15 Ver 3.22B2 Add EEG wave data ASCII save.
2004.09.16 Ver 3.30B2 Probably adapted for Windows NT/2000/XP
2004.10.02 Ver 3.31B2 memory leak bug fixed
2006.06.14 Ver 3.33B2 trend fixed
2007.05.15 Ver 3.34B2 COM portをCOM16まで使用できるように拡張.
2010.09.09 Ver 3.50B2 EEGのsampling rateを256Hzも利用できるように拡張.
2011.10.03 Ver 3.51B2 artifact checking modified.C++Buidler2010で構築.
2011.11.23 Ver.3.52B2 Add Power Scale added.
2012.01.03 Ver 3.53B2 C++Builder XE2で構築.


Copyright (c) 1999-2012 Satoshi Hagihira (hagihira@anes.med.osaka-u.ac.jp)


9. おわりに

欧米ではBIS モニターが普及してきているようですが,私は近い将来現在のECGのように麻酔医がごく当たり前にEEGを見ながら麻酔管理を行うようになるのではないかと思っています.BSAを動かしながら麻酔しているとそのような気になってしまいます.BISの値のみを見るのはちょうどパルスオキシメータで波形を見ずに値だけを見ているのに似ていると思われます.我々は常に原波形を見るべきです.(BIS monitorでも原波形は見ることができますが,同時にPower spectrumまで見ることはできません.)
麻酔薬によって脳波波形の変化には違いがありますが,脳波波形そのものを見ているだけでもかなり麻酔の深さは判断できると思います.さらにBSAのようにBispectrumやPower Spectrumも一目で判れば臨床上もかなり参考にできると考えています.なお,BISモニターは臨床使用を目的に開発された「モニター」であり,artifact (ノイズ)対策にかなりの精力を注いでいるようです.また一部には波形を補間しているともされています.このような波形に対する操作は測定装置という意味ではやや問題があります.研究目的で使用する場合には内部がはっきり判らないだけでなくこういった点も問題になると思います.一方BSAは研究を主眼にして開発したものですがBSA for BISおよびBSA for A2000はBISの出力を利用することでBISの足らない部分が補えると考えられます.V3.00B以降では演算間隔を10秒に短縮しており,速い変化にも追従できるようになっています.
このソフトウェアは共同研究していただける方には配布します.研究に使用したい方は私に直接連絡を下さい.研究目的ではなく単にBISモニターの補助として使って頂くことに対してはフリーに使用していただいても構いません.使用に当たって一つだけお願いがあります.もしBsa for A2000を使用している症例で術中覚醒を来した症例がありましたら,その時の麻酔薬の使用量やBsa for A2000で得られた各脳波パラメータ(できれば生の脳波データ)を頂けないでしょうか.どういう時に術中覚醒が起こるのか(その時の実際の脳波パターンはどうなっているのか)知りたいのです.私の研究の大きな目的の一つは術中覚醒が起こる時の状況を正確に把握し,これを防ぐ方策を考えることです.ぜひ協力をお願いしたいと思います.
著作権は萩平に帰属します.内容に関して保証はできませんが,演算ルーチンにbugはないと思います.但し,SynchFastSlowの演算方法はBISのものが判りませんので私の作成したパラメータはBispRatioとしています.おそらくほぼSynchFastSlowと同等だと思いますが不明です.
Ver 1.37B以降ではBispectrumとBicoherenceの計算範囲をf1 =f2 の場合も計算するように変更しました.その結果0.5Hz<=f2 <=f1 <=47.0Hz(f1 +f2 <=47.5Hz)の範囲で計算するようになりました.これに合わせてBispRatioもf1 =f2 まで含めて計算するようにしました.BispRatioの値は以前のバージョンのものと若干異なりますが,ほとんど差はないと思います.
旧バージョンではWindowsの画面制御が時々おかしくなり画面が乱れたことがありました.Ver1.21でやっとこの問題に対応できました.
ASPECT社がSynchFastSlowの演算方法やBISの算出方法を公開した場合にはこれに対応したいと思います.(まず公開されないと思いますが...)
また,ご意見やご希望がありましたらEmailで連絡をいただけないでしょうか?

参考文献

  1. Rampil IJ: A Primer for EEG Signal Processing in Anesthesia. Anesthesiology 1998;98(4), 890-1002
  2. Glass PS, Bloom M, Kearse L, Rosow C, Sebel P, Manberg P: Bispectral Analysis Measures Sedation and Memory Effects of Propofol, Midazolam, Isoflurane, and Alfentanil in Healthy Volunteers. Anesthesiology 1997;86(4), 836-47
  3. Sigl JC, Chamoun NG: An intruduction to bispectral analysis for the electroencephalogram. J Clin Monit 1994;10, 392-404
  4. A-20x0 SERIAL PORT TECHNICAL SPECIFICATION, provided by ASPECT INC.
  5. Nikias CL, Raghuveer MR: Bispectrum estimation: A digital signal processing framework. Proc. IEEE, 1987;75, 869-91
  6. Hagihira S, Takashina M, Mori T, et al: Practical Issues in Bispectral Analysis of Electroencephalographic Signals. Anesth Analg, 2001;93(4),966-70
  7. Hagihira S, Takashina M, Mori T, et al: Changes of Electroencephalographic Bicoherence during Isoflurane Anesthesia combined with Epidural Anesthesia. Anesthesiology, 2002;97(6), 1409-15
  8. Hagihira S, Takashina M, Mori T, et al: Electroencephalographic Bicoherence is Sensitive to Noxious Stimuli during Isoflurane or Sevoflurane Anesthesia. Anesthesiology, 2004;100(4), 818-825

大阪大学大学院医学系研究科 生体統御医学 麻酔・集中治療医学講座 萩平 哲(はぎひら さとし)
565-0871 大阪府吹田市山田丘 2-2 Tel. 06(6879)-3133, Fax. 06(6879)-3139
Email: hagihira@anes.med.osaka-u.ac.jp , satoshi.hagihira@nifty.com